Design for Learning: Web Design Seminar

An Introduction to Dreamweaver

2/01/2002
10:00 AM
**Table of Contents**

1. The Dreamweaver Interface .................................................. Page 3
2. Defining a Dreamweaver site ................................................. Page 4
3. Creating a new Dreamweaver page ......................................... Page 6
4. Inserting a Picture on to a page ........................................... Page 7
5. Creating tables for alignment and control ............................... Page 8
6. Adding Text and Text links to a page ....................................... Page 9
7. Creating image links and hotspots ........................................ Page 10
8. Creating simple Image rollovers ............................................ Page 10
9. Creating and modifying Templates ......................................... Page 13
10. Web Resources ....................................................................... Page 17
1. The Dreamweaver Interface

Object Palette
The Object palette contains tools that allow you to add a wide variety of content to your pages. The default panel in the Object palette is the Common panel, which contains a number of buttons that allow you to add various elements to Web pages, including images, tables, rules, and external objects, such as Flash or Shockwave files. In addition, the drop-down list at the top of the Object palette allows you to access other panels. The Characters panel lets you add typographic characters to your pages. The Forms panel contains tools to help you to build Web-based forms. The Frames panel contains buttons that assist you in building a frameset. The Head panel lets you add meta tags to your pages. The Invisible panel allows you to add anchors and other elements such as non-breaking spaces to your pages.

Launcher
The Launcher contains buttons that open and bring forward a number of important Dreamweaver windows to the front of the document windows, including the Site window and the HTML inspector.

Property Inspector
The Property inspector contains settings that allow you to specify the properties of text and other objects that you place on Web pages. The settings in the Property inspector change to reflect the particular object you are working with. You can use the Property
inspector to format text, set table borders, specify link destinations, and many other attributes of page objects.

The Site Window
The Site window will be an integral tool when building a site. The Site window allows you to view and manage the various files that comprise the site. In addition, you will use the Site window to upload files to a Web server.

2. Defining a Dreamweaver site

Before you create several Web pages for your site, it is a good idea to plan your entire site as much as possible ahead of time. By thinking about the overall look and structure of the site prior to building it, you can prevent spending hours editing numerous pages that need to be changed to fit a revised design.
It is also important to think in detail about the message you wish to convey by creating the Web site. The concepts you choose will dictate the content of the site, and will help you decide how to organize the information.

Before creating any individual pages, you should have a plan for how the viewer will navigate through your site. You must provide a clear, simple way for viewers to find information, and for them to know where they are in the overall site. It is easy to create Web sites that confuse the viewer or make them feel lost in a disorganized array of information.

In Dreamweaver, a defined site is the depository of all of the files necessary for the Web site's operation, including HTML files, graphics, and other objects. Defining a site offers the following advantages:

• Dreamweaver can display the site in the Site window, which shows all of the files contained in the site, and their linking relationships.

• You can use the Site window to easily add and update links to Web pages.

• You can use the Site window to arrange and rearrange the folder structure within the site without having to manually re-establish links between pages.

• By defining a site, Dreamweaver creates the structure of what will become the remote Web site, so that you can manage and check the site before uploading it.

**Lab 1:**
Objective: To define a site, including designating a Site folder.
Setup: As you begin this lesson, Dreamweaver should be active.

1. You will now define the Joe Boxer Web site. Choose Site-> New Site. The Site Definition dialog box appears.

2. Make sure that "Local Info" is selected in the "Category" list.

3. Type Joe Boxer in the "Site Name" field. You must now select a folder on your hard disk to designate as the Joe Boxer Web site folder.

4. Click on the folder icon to the right of the "Local Root Folder" field. The Choose Local Folder dialog box appears.

5. Navigate to the Web seminar folder.

6. Click on the “Joe Boxer folder and click “Open”. "Joe Boxer” now appears in the “select” field.
7. Click “Select”. You have selected the “Joe Boxer” folder as the place where your new web site files will reside. As a result all of your files must be within this folder or a subfolder within the “Joe Boxer” site folder.

8. You have specified the basic settings for defining a site. Click “OK”.

9. An alert box appears asking if you want to create a cache file for the site. Click “Create”. Dreamweaver examines the files in the “Joe Boxer” folder you defined and then displays them in the Site Window.

10. Your site is now defined.

3. Creating a new Dreamweaver page
The home page is the first page the viewer sees when accessing your Web site. From the home page, the viewer can typically navigate to several other pages via hyperlinks on the page. Usually the hyperlinks are provided in the form of colored, underlined text, as well as images that the viewer can click on.

It is important to decide what the contents of your home page will be. A common mistake is to make a home page somewhat of a "warehouse of information." Instead, you should think of the home page as more of a springboard to the information contained on other pages.

It is usually better to make your home page graphically appealing with clear navigational cues to the viewer than it is to put a lot of information on the home page using small text. The former approach informs the viewer of the scope of your site, while the latter inundates the viewer with too much detail.

You will design the home page with five main topics, and you will create both an image and text link to other pages on the site from the home page.

Lab 2:
Objective: To designate a home page that will act as a center point for your site and modify the page properties

1. From the Site window, choose File -> New Window (Keyboard Shortcut: CTRL N). A new untitled document window appears. You will title the page, choose the background color and background image, and save the page as the home page for the site.


3. Type “Joe Boxer” in the “Title” field.
4. Next you will choose the background color for this page. Once again, you will use a color that is similar to the graphics you will be inserting later. graphic will not be distracting to the viewer. **Type #CCCCCC in the "Background" field.**

5. Next you will choose the colors for the text and links on this page. **Type #000000 in the "text" field** or select a black color from the color selector next to the “text” field.

6. **Type #990000 in the "Visited Links" field** or select a burgundy color from the color selector next to the “Visited Links” field.

7. **Type #666666 in the "Active Links" field** or select a grey color from the color selector next to the “Active Links” field.

8. **Type #0000CC in the "Links" field** or select a blue color from the color selector next to the “Links” field.

9. **Place a “0” (zero) in the field next to the Left Margin.**

10. **Place a “0” (zero) in the field next to the Margin Width.**

11. **Place a “0” (zero) in the field next to the Top Margin.**

12. **Place a “0” (zero) in the field next to the Margin Height.**

13. **Click "OK".** This will return you to the document.

14. You will now save the home page. **Choose File -> Save** (Keyboard Shortcut: CTRL S). The Save dialog box appears.

15. **Type index. html in the "Name" field.**

16. Make sure that the file will be saved in the "Joe Boxer" folder.

17. **Click "Save."** The file is saved with the name "home.html"

### 4. Inserting a Picture on to a Page
Adding graphics and images are an important part of the web design process. The following section will help you to accomplish this within Dreamweaver.

**Lab 3:**
Objective: To place the banner image for the “Joe Boxer” Site at the top of the page and then center it in the middle of the page.

Setup: As you begin this lesson, the home.html page that you created in the previous section should be open. The Property inspector should also be open.
1. **Place your cursor in the spot in which you want the image to be placed.** From the Site window, **choose Insert -> Image.** A dialog box will open and prompt you to select the image that you want to insert into the home.html page.

2. **Navigate to the Web seminar folder.**

3. **Double Click on the “Joe Boxer” folder** to open it up.

4. **Double Click on the “images” folder** to open it up.

5. **Highlight the “boxer.gif” image** and the click “Ok”

6. The Joe Boxer Banner image should now be placed on the page.

7. Next we need to center the banner. **Click on the banner image and select the center object option in the Property Inspector.**

8. The Joe Boxer Banner image should now be centered on the page.

5. **Creating tables for alignment and control**

Tables are extremely helpful in creating basic layouts on web pages. The purpose of tables is to help hold images and text in place so that they compliment one another in the overall design of a web page.

**Lab 4:**

**Objective:** To create a basic table for holding graphics and text for the Joe Boxer site. Once we create the site we will center it as we did with the banner.

**Setup:** As you begin this lesson, the home.html page that you created in the previous section should be open. The Property inspector should also be open.

1. **Place your cursor in the spot in which you want the table to be placed.** From the Site window, **choose Insert -> Table.** A dialog box will open and prompt you to define the table that you want to insert into the home.html page.

2. Once the Insert Table dialog box open **type “1” in the “Rows” field.**

3. Then **type “2” in the “Columns” field.**

4. Then **type “670” in the “Width” field** and **select pixels from the drop down menu to the right of the “width” field.**

5. Then **type “0” in the “Borders” field.**

6. Then **click “OK”.**
7. Next we need to center the table. **Click on the table and select the center option** from the Align dropdown menu in the Property Inspector.

8. The table should now be centered on the page.

9. Place your cursor in the middle of the table, directly over the center divider, click your mouse and drag the divider line to left of the table so that the left cell is now smaller than the right table cell.

10. Finally, place your cursor in the left cell of the table. Locate the Property inspector and select left from the “Horz” dropdown menu and select “Top” from the “Vert” dropdown menu.

### 6. Adding Text and Text links to a page

**Lab 5:**

*Objective:* To create a basic text navigation bar at the bottom of the page. You will then convert the text into links. In addition, will also add some copyright information and then center all of the text.

*Setup:* As you begin this lesson, the home.html page that you created in the previous section should be open. The Property inspector should also be open.

1. Place your cursor beneath the table that you just created.

2. Type “HOME || ABOUT US || SHORTS || EMAIL”.

3. Press Enter.

4. Type “Copyright 2001, Joe Boxer Incorporated”.

5. Press Enter.

6. Highlight all of the text that you just typed with your mouse.

7. From the Site window, **choose Text -> Align -> Center**. The text will now be centered on the page.

8. Now we begin to create text links. Highlight the word “HOME” with your mouse. Locate the Property Inspector and type [home.html](#) in the “Link” field. Press enter.

9. Highlight the word “ABOUT US” with your mouse. Locate the Property Inspector and type [about.html](#) in the “Link” field. Press enter.

10. Highlight the word “SHORTS” with your mouse. Locate the Property Inspector and type [shorts.html](#) in the “Link” field. Press enter.
11. Highlight the word “HOME” with your mouse. Locate the Property Inspector and type mailto:joe@boxerinc.com in the “Link” field.

12. Press F12 to preview the links in the Web browser.

7. Creating image links and hotspots
Dreamweaver also allows us to make images, or just sections of images, into hyper-links.

Lab 6:
Objective: To make a small section of the “Joe Boxer” banner a hyper-link. This is called creating a Hotspot.
Setup: As you begin this lesson, the home.html page that you created in the previous section should be open. The Property inspector should also be open.

1. Click on the image of the “Joe Boxer” banner. Locate the Property Inspector and click on the button in the lower left corner with a green square on it.

2. Place your mouse over the section of the banner that reads “Joe Boxer Inc.” Hold your mouse down and drag a rectangle across the section of the banner that reads “Joe Boxer Inc.” until it is covered.

3. Once you release your mouse the property Inspector will change and offer you options on creating a link for your Hotspot. Locate the “Link” field and type home.html in the field. Press enter.

4. The hotspot link is now created. Press F12 to preview the link in the Web browser.

8. Creating simple Image rollovers
Lab 7:
Objective: To create a basic image navigation bar with rollovers and place the images within the table that we created previously. We will also link the rollover images to other sections of the site that we are building.
Setup: As you begin this lesson, the home.html page that you created in the previous section should be open. The Property inspector should also be open.

1. Place your cursor in the left cell of the table that we previously created and click your mouse to select the cell.

2. You are ready to create the first rollover. Click the Insert Rollover Image button in the Object palette.

3. The Insert Rollover image dialog box will appear. Click the "Browse" button next to the "Original Image" field. The Original Image dialog box appears.
4. Navigate to the "images" folder inside the "Joe Boxer" folder inside the "Web seminar" folder.

5. Click on "homebut.gif" and click "Select."

6. A dialog box may appear, warning you that Dreamweaver cannot create a complete document relative path if the document you are working on has not been saved. Once you save the file, however, Dreamweaver will create the path. If the alert dialog box appears, check the "Don't Show Me This Message Again" checkbox, then click "OK"

7. Then return to the Insert Rollover image dialog box. Next you will select the image that will appear when the viewer's cursor moves over the first image. Click the "Browse" button next to the "Rollover Image" field. The Rollover Image dialog box appears.

8. Click on "homebut_f2.gif" and click "Select."

9. Then return to the Insert Rollover Image dialog box. You will now specify a name for the image on the page. Naming the image makes it easier to keep track of them when you use them with behaviors. Type “home” in the "Image Name" field.

10. At this point, you will specify the link for the button using the "Link" field. Type home.html in the “Link” field and Press enter (Please note that you can always change a link for a rollover after you have created it by entering the link in the "Link" field in the Property inspector).

11. Make sure that the "Preload Images" checkbox is currently checked. You want Dreamweaver to pre-load the images when the page loads so that there is no delay when the viewer moves the cursor over the image. While the initial images will take longer to load, this provides a smoother experience for the viewer.

12. Click "OK"

11. Once you return to the document, the "Home" rollover is placed on the page. You will create additional rollovers using the above technique. Click to place the insertion point to the right of the "Home" rollover image.

12. Press ENTER The insertion point is now below the first rollover.

13. Click the Insert Rollover Image button in the Object palette. The Insert Rollover Image dialog box appears.

14. Click the "Browse" button next to the "Original Image" field. The Original Image dialog box appears.

15. Click on "aboutbut.gif" in the file list and click “Select."
16. Then return to the Insert Rollover Image dialog box. You will now select the rollover image. Click the "Browse" button next to the "Rollover Image" field. The Rollover Image dialog box appears.

17. Click on "aboutbut_f2.gif" and click "Select."

18. Then return to the Insert Rollover Image dialog box. You will now specify the name for the image. Type “About Us” in the "Image Name" field.
19. Now specify the link for the button using the "Link" field. Type about.html in the "Link" field and Press enter

20. Click "OK" to return the document. You have created the "About Us" rollover.

21. Using the above technique, create another rollover below the "About Us" rollover, using the "shortbut.gif" and "shortbut_f2.gif" images.

21. Name the image placeholder "Shorts".

22. Now specify the link for the button using the "Link" field. Type shorts.html in the “Link” field and Press enter

23. Using the above technique, create another rollover below the "Shorts" rollover, using the "emailbut.gif" and the "emailbut_f2.gif" images.

24. Name the image "Email."

25. Now specify the link for the button using the "Link" field. Type mailto:joe@boxerinc.com in the “Link” field and Press enter.

26. Now save the page and then preview it in your browser. Choose File -> Save (Keyboard Shortcut: CTRL S).


28. Position the cursor over each of the rollovers. As the cursor moves over an image, the cursor changes to a pointing hand, and the image switches. When the cursor leaves the image, the image reverts back to the original.

29. Exit the browser to return to Dreamweaver. You return to Dreamweaver.

30. Finally, place your cursor on the center divider of the table, click your mouse and drag the divider line to left of the table so that the divider line is now nearly flush against the rollover images.
9. Creating and modifying Templates

Lab 9:
Objective: To create a template for the basic “Joe Boxer” site pages. We will then use the templates to quickly create pages for the rest of the site.
Setup: As you begin this lesson, the home.html page that you created in the previous section should be open. The Property inspector should also be open.

Creating the template
1. With the home.html page open, choose File -> Save as Template. The Save as Template dialog box appears. You will first choose the site that you are creating the template for.
2. Choose "Joe Boxer" from the "Site" drop-down list, if necessary.
3. You will now name the template. Type “Basictemp” in the "Save As" field.
4. Click "Save." The document window of the template you created now displays the title of the template with the ".dwt" file extension.

A template may contain two types of regions: editable and non-editable. An editable region is an area of a template that contains changeable content, such as text that varies form page to page, or graphics that will change on various pages. A non-editable region contains elements that will stay the same when you use the template, such as company logos or navigation aids. In order for you to be able to add or change anything in a page created with a template, you need to create at least one editable region.

5. You will now define one editable region for the template. Click in the right cell of the table that we created previously to place the insertion point.
7. Type “content” in the "Name" field and click "OK." The name of the region you create appears within the curly brackets at the location of the insertion point. Now you have finished designing the template for use with the basic Joe Boxer pages.
8. Close the template window. An alert box appears asking if you want to save the template.
9. Click "Yes." You will apply the template to several pages later. A new "Templates" folder is automatically created within the site folder. The "Templates" folder will contain any templates you create. By creating a template, you can create new Web pages based on the template page, so that you do not need to have to repeatedly specify common
Creating and modifying new pages from the template
1. From the Site window, choose File->New from Template. A Select Template dialog box appears. You will first choose the site that you are creating the template for, which in this case is “Joe Boxer”. Choose "Joe Boxer" from the "Site" drop-down list, if necessary.

2. Now select the template named “Basictemp” in the "Template" field.

3. Click “Select”. A new, untitled document based on the template will now appear. You will notice that only the area that you previously specified as a Editable region can be changed. It is here that you will place the text for this page.

4. Navigate to the "raw files" folder inside the "Joe Boxer" folder.

5. Click on "indextext.doc" file to open Microsoft word.

6. From within Microsoft Word, highlight all of the text on the page and copy it to your clipboard.

7. Return to Dreamweaver and place your cursor in the editable area of the new document that is based on the template. Choose Edit -> Paste in order to place the text from the indextext.doc Word file into the editable area.

8. Use the text tools in the property inspector to format the text in a manner that most suits you.

9. Place your cursor next to the first paragraph of the document and choose Insert -> Image from the document window. Once the dialog box open up, navigate to the images folder inside the “Joe Boxer” folder and select the “pattern_bball_small.gif” image.

10. While the image is still highlighted, locate the Property Inspector and select the left option from the Align dropdown menu.

11. Place your cursor next to the third paragraph of the document and choose Insert -> Image from the document window. Once the dialog box open up, navigate to the images folder inside the “Joe Boxer” folder and select the “pattern_darthvader_small.gif” image.

12. While the image is still highlighted, locate the Property Inspector and select the right option from the Align dropdown menu.
13. **Choose File -> Save As.** Once the Save As dialog box opens, save the document as the new **home.html**.

14. From the Site window, **choose File->New from Template.** A Select Template dialog box appears. You will first choose the site that you are creating the template for, which in this case is “Joe Boxer”. Choose "Joe Boxer" from the "Site" drop-down list, if necessary.

15. Now **select the template named “Basictemp”** in the "Template" field.

16. **Click “Select”.** A new, untitled document based on the template will now appear.

17. **Navigate to the "raw files" folder inside the "Joe Boxer" folder.**

18. **Click on "abouttext.doc" file to open Microsoft word.**

19. From within Microsoft Word, highlight all of the text on the page and copy it to your clipboard.

20. Return to Dreamweaver and place your cursor in the editable area of the new document that is based on the template. **Choose Edit -> Paste** in order to place the text from the **abouttext.doc** Word file into the editable area.

21. Use the text tools in the property inspector to format the text in a manner that most suits you.

22. Place your cursor next to the first paragraph of the document and **choose Insert -> Image** from the document window. Once the dialog box open up, navigate to the images folder inside the “Joe Boxer” folder and **select the “pattern_cow_small.gif” image.**

23. While the image is still highlighted, locate the Property Inspector and select the left option from the Align dropdown menu.

24. **Choose File -> Save As.** Once the Save As dialog box opens, save the document as the about.html page.

25. From the Site window, **choose File->New from Template.** A Select Template dialog box appears. You will first choose the site that you are creating the template for, which in this case is “Joe Boxer”. Choose "Joe Boxer" from the "Site" drop-down list, if necessary.


27. **Click “Select”**. A new, untitled document based on the template will now appear.
28. Navigate to the "raw files" folder inside the "Joe Boxer" folder.

29. Click on "Styleboxers.doc" file to open Microsoft word.

30. From within Microsoft Word, highlight all of the text on the page and copy it to your clipboard.

31. Place your cursor in the editable area of the document and Type “The Boxers”. Center the text and hit Enter.

32. Choose Insert -> Table from the document window. Once the dialog box open up, insert a table with 2 rows, 3 columns, a width of 560 pixels, a and border of 0. Click “OK” to return to the document.

33. Press Enter.

34. Repeat step 32 two more times. When you are done there should be three separate tables within the editable area of the document.

35. Now paste the text from the Styleboxers.doc word file into each of the bottom table cells of the tables you just created. Center the text and hit return. Then choose Insert -> Image from the document window. Once the dialog box open up, navigate to the “images” folder inside of the “Joe Boxer” folder and select the “addtocart_brn.gif” image.

36. Next, select each of the upper cells of the tables that you just create and insert a Boxer short image into each cell. Images of the Boxer Shorts can be found in the “images” folder inside the “Joe Boxer” folder.

37. Finally, choose File -> Save As. Once the Save As dialog box opens, save the document as shorts.html.

38. Congratulations! You have created a site. Test it in your Browser (F12).
10) Web Design Workshop Resources

Macromedia Forums – Dreamweaver, Fireworks and Flash support groups
http://www.macromedia.com/support/forums/

Dreamweaver – Dreamweaver tutorials
http://www.dwfaq.com

Lynda.com - Video tutorials and products
Fireworks Videos Tutorials


Dreamweaver Video Tutorials


Designs by Mark – Design Tutorials
http://www.designsbymark.com/

Free Layouts.com - Free DW Templates
http://www.freelayouts.com/

JimWORLD - Free DW Templates
http://www.freesitetemplates.com/

Yale Style Manual - Design resources
http://info.med.yale.edu/caim/manual/

PageResource.com- by The Web Design Resource
http://www.pageresource.com/

Cool Homepages - Design resources
http://www.coolhompages.com/

AAA - Backgrounds - Background Categories
http://www.aaa-backgrounds.com/

Cool Archive - Free Clip Art and Fonts
http://www.coolarchive.com/

Clipart.Com – Free clip art and images
http://www.clipart.com/